欢迎光临
我们一直在努力

IDEA导入maven中net.sf.json报错的解决方法

IDEA搭建spring boot项目,用maven导入jar包时,

添加net.sf.json的jar包依赖,然后导入 json-lib-2.4-jdk15.jar 的时候一直导不成功,install报错

 Could not find artifact net.sf.json-lib:json-lib:jar:2.4 in central (https://repo.maven.apache.org/maven2)
Missing artifact net.sf.json-lib:json-lib:jar:2.4:compile

reimport  多次也没成功, 求助万能网友找到了解决办法

就是在导入的时候加jdk的版本号 :

<!-- https://mvnrepository.com/artifact/net.sf.json-lib/json-lib -->
<dependency>
    <groupId>net.sf.json-lib</groupId>
    <artifactId>json-lib</artifactId>
    <version>2.4</version>
    <classifier>jdk15</classifier>
</dependency>

完了之后自动导入的,结果导入成功;

如果不添加<classifier>jdk15</classifier>会报如下 错误:

Could not find artifact net.sf.json-lib:json-lib:jar:2.4 in central (https://repo.maven.apache.org/maven2)
Missing artifact net.sf.json-lib:json-lib:jar:2.4:compile


错误原因,net.sf.json添加的时候需要添加jdk的版本号,第一次听说,于是有了上面的配置

结果,错误没有了,编译通过了。
因为文件名叫json-lib-2.4-jdk15.jar……

赞(0)
版权归原作者所有,如有侵权请告知。达维营-前端网 » IDEA导入maven中net.sf.json报错的解决方法

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址